Google is expereicning issues with Chromebook logins

Incident Report for GoGuardian

Resolved

Update: Google has indicated that the incident affecting Chromebook logins has been fully resolved.

https://support.cloud.google.com/portal/system-status?product=WORKSPACE

Thank you for your patience and understanding.
Posted Nov 04, 2025 - 10:38 PST

Update

We are continuing to investigate this issue.
Posted Nov 04, 2025 - 10:04 PST

Investigating

We are currently monitoring a reported issue affecting Google Chromebooks, where users are experiencing login difficulties. This issue is impacting both staff and students using Chromebooks.

Our teams are actively monitoring the situation. We’ll provide updates as more information becomes available.

Google Outage Page https://downdetector.com/status/google/
Posted Nov 04, 2025 - 09:58 PST
This incident affected: Content Filtering, Admin: Dashboard, Teacher: Dashboard, Teacher: Classroom Connections, Organization Management, Fleet: Dashboard, GoGuardian Beacon (Alerts, Notifications, Settings, Dashboard, Quick View, Alert Details, Global Search), and GoGuardian Admin 2.0 (Dashboard, Penalty Box, Simulator, Policies, Alerts, Theft Recovery, YouTube Filtering, GoGuardian Admin Gateway).