Degraded Performance: Organization Management - Product Selector

Incident Report for GoGuardian

Resolved

We have fully resolved an issue with Organization Management
If you are still experiencing trouble, please reach out to our support team.

Thank you for your patience.
Posted May 06, 2026 - 08:09 PDT

Update

We are continuing to investigate this issue.
Posted May 06, 2026 - 08:07 PDT

Investigating

As of approximately 7:39am pacific we have noticed that the Product Selector may be missing from Organization Management. Our team is currently investigating the issue.

We sincerely apologize for any inconvenience.
Posted May 06, 2026 - 07:41 PDT
This incident affected: Organization Management.