GGT Classroom degraded experience

Incident Report for GoGuardian

Resolved

We have resolved the issue that resulted in increased reports of degraded performance when starting classroom sessions in GoGuardian Teacher. Your sessions should now work as expected. Thank you for your patience and we apologize for any inconvenience caused by this issue.
Posted Mar 03, 2026 - 14:03 PST

Investigating

It looks like some users are experiencing trouble starting classroom sessions within GoGuardian Teacher, starting at approximately 1PM Pacific Time. We are currently investigating the issue and working towards a fix. We will keep you updated with additional details. We sincerely apologize for any inconvenience.
Posted Mar 03, 2026 - 13:34 PST
This incident affected: Teacher: Dashboard.