Degraded Performance: GoGuardian Admin – DNS Filtering

Incident Report for GoGuardian

Monitoring

Functionality has been restored for affected users as of approximately 2:00 PM PDT.

After the September 8 incident, we increased compute on the existing DNS servers. Today's issue showed we also needed much more network capacity to handle peak query volume. We added capacity to restore service. We have since moved the DNS edge onto larger, network-optimized infrastructure.

We are actively monitoring GoGuardian Admin DNS Filtering. We sincerely apologize for the disruption.
Posted Sep 10, 2026 - 20:50 PDT

Investigating

As of approximately 11:29 AM PDT, we have seen an increase in reports of delayed and/or failed resolution times within GoGuardian Admin DNS Filtering. Our team is currently working to resolve this issue and will keep you updated as we implement a fix.
We sincerely apologize for any inconvenience.
Posted Sep 10, 2026 - 11:54 PDT
This incident affects: GoGuardian Admin Features (DNS Filtering).