GoGuardian Teacher Degraded Performance

Incident Report for GoGuardian

Resolved

We successfully deployed a fix to address reports of trouble loading classrooms within GoGuardian Teacher. All internal latency metrics have returned to normal after an additional fix was deployed on Friday, March 7, 2025, and the majority of customers who reported latency have confirmed their performance has returned back to normal. To ensure your browser has received updates, please refresh your GoGuardian Teacher dashboard using CTRL+SHIFT+R (Windows/ChromeOS) or CMD+SHIFT+R (Mac) to ensure your GoGuardian Teacher is updated.

If you continue to run into trouble with latency, please submit a case https://support.goguardian.com/s/contactsupport and include the URL you are on when seeing the slowness or latency from your address bar, and what action you're attempting (using Groups for example) when you see it most.

Thank you for your patience while we have worked to address this issue.
Posted Mar 10, 2025 - 13:06 PDT

Monitoring

We have deployed a fix to address reports of trouble loading classrooms within GoGuardian Teacher. Please refresh your GoGuardian Teacher dashboard using CTRL+SHIFT+R (Windows/ChromeOS) or CMD+SHIFT+R (Mac) to ensure your GoGuardian Teacher is updated.

If you continue to run into trouble with latency, please submit a case https://support.goguardian.com/s/contactsupport and include the URL you are on when seeing the slowness or latency from your address bar, and what action you're attempting (using Groups for example) when you see it most.

Thank you for your patience while we have worked to address this issue.
Posted Mar 06, 2025 - 13:08 PST

Investigating

Some users may experience trouble loading classroom data within GoGuardian Teacher, starting at approximately Wednesday, March 5th, 2025. Users have reported slowness while using GoGuardian Teacher. So far, not all teachers seem to be impacted, but the number of reports has grown in the past 24 hours. Teachers attempting to monitor larger classrooms may be more likely to experience trouble with latency. We are currently investigating the issue and working towards a fix. We will keep you updated here with additional details. We sincerely apologize for any inconvenience caused by this issue.
Posted Mar 06, 2025 - 10:39 PST
This incident affected: Teacher: Dashboard and Teacher: Classroom Connections.