GoGuardian Teacher video calling and presentation outage
Incident Report for GoGuardian
Resolved
We have successfully resolved an issue affecting video calls and presentations within GoGuardian Teacher. Video calls and presentations should now work as expected. We apologize for any trouble this may have caused.
Posted Mar 01, 2022 - 14:20 PST
Investigating
We are currently investigating an issue causing video calls and presentations within GoGuardian Teacher to not work as expected. We apologize for any trouble this may cause.
Posted Mar 01, 2022 - 10:56 PST
This incident affected: Teacher: Classroom Connections.