GoGuardian Teacher Outage
Incident Report for GoGuardian
Resolved
This incident has been resolved.
Posted about 2 months ago. Oct 17, 2018 - 12:33 PDT
Investigating
We are currently investigating reports of teachers using GoGuardian Teacher getting stuck on blank pages and the inability to start classroom sessions. We apologize for the trouble this may cause.
Posted 2 months ago. Oct 17, 2018 - 11:11 PDT
This incident affected: Teacher: Dashboard and Teacher: Classroom Connections.