Degraded Performance: GoGuardian DNS Filtering

Incident Report for GoGuardian

Resolved

This incident has been resolved and the GGDNS Filtering should be fully operational. Sorry for the inconvenience.
Posted Mar 27, 2026 - 11:31 PDT

Identified

As of approximately 12:38pm ET, we have seen some increase in latency for Admin DNS Filtering. Our team is currently working to resolve this issue and will keep you updated as we implement a fix.

We sincerely apologize for any inconvenience.
Posted Mar 27, 2026 - 10:27 PDT
This incident affected: GoGuardian DNS (GGDNS Filtering).