GoGuardian Theft Recovery

Incident Report for GoGuardian

Resolved

The issue with GoGuardian Theft Recovery has been fully resolved.
Posted Jul 31, 2026 - 09:22 PDT

Investigating

We are currently investigating a potential bug within GoGuardian Theft Recovery. We are receiving intermittent reports of the authentication page creating a loop making it temporarily inaccessible. We will provide updates as we learn more from our investigation.
Posted Jul 31, 2026 - 09:10 PDT
This incident affected: GoGuardian Admin.