GoGuardian Degraded Performance
Incident Report for GoGuardian
Resolved
We have made improvements to - and have eliminated several instances of queries timing out for GoGuardian Admin, Teacher, Beacon, DNS, and Parent. Accounts with significantly more data than others were primarily affected by the ongoing performance degradation since on or about 9/18/2020. Queries may still take some time to fully load sections of the admin dashboard, but they are no longer timing out. We apologize for any inconvenience caused throughout the duration of this issue.
Posted Oct 29, 2020 - 13:15 PDT
Monitoring
We have made significant improvements to our infrastructure which holds and distributes historical report data for GoGuardian Admin, GoGuardian Teacher, GoGuardian Beacon, GoGuardian DNS, and GoGuardian Parent and are seeing more consistent query performance across the board. We are continuing to make optimizations and closely monitoring performance. Thank you for your patience and apologies for any inconvenience caused over the duration of this incident.
Posted Sep 29, 2020 - 18:56 PDT
Investigating
We are currently investigating an issue causing delays and inconsistency for GoGuardian Parent data, DNS reporting data, GoGuardian Admin student history, GoGuardian Admin dashboard panels, GoGuardian Beacon browsing history, GoGuardian Teacher timelines, and GoGuardian Teacher session summary report emails. GoGuardian Admin and Teacher Filtering is fully functional and should continue to work as expected. We apologize for any trouble this may cause.
Posted Sep 17, 2020 - 13:10 PDT
This incident affected: GoGuardian Admin 2.0 (Dashboard), GoGuardian Parent (GoGuardian Parent Application), Admin: Dashboard, Teacher: Dashboard, GoGuardian DNS (GGDNS Reporting), and GoGuardian Beacon (Alert Details).