GoGuardian Teacher Dashboard
Incident Report for GoGuardian
Resolved
This incident has been resolved.
Posted about 1 year ago. Aug 31, 2016 - 10:07 PDT
Investigating
Our engineers are currently investigating an issue causing students to improperly connect to GoGuardian Teacher sessions at some schools. Teachers and admins may see delays or trouble viewing student Screens & student Timelines.

For updates on our current status please subscribe to our status page: http://status.goguardian.com/#
Posted about 1 year ago. Aug 31, 2016 - 09:10 PDT