Degraded Performance with GoGuardian for Teacher's dashboard and student device connections
Incident Report for GoGuardian
Resolved
The GoGuardian for Teachers dashboard is now fully operational. If you continue to experience issues, please contact support by emailing support@goguardian.com.
Posted almost 4 years ago. Aug 28, 2015 - 14:23 PDT
Identified
We are experiencing degraded performance with GoGuardian for Teachers. Users may experience slow loading and dropped connections to student devices.
Posted almost 4 years ago. Aug 28, 2015 - 10:09 PDT